Version Support starting August 1, 2014

In order to best serve all users and institutions, we will no longer be supporting versions of Qwickly prior to version 2.1 as of August 1, 2014.  Please note, you can upgrade to the latest version of Qwickly completely free at http://www.goqwickly.com/download.  If you have questions or technical difficulties, please contact Qwickly Support.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk