What version of Blackboard is required?


Qwickly should work on any modern version of Blackboard Learn, version 9.1. Qwickly is supported on Self-Hosted, Manage-hosted and SaaS versions of Blackboard.

Please note that Qwickly tools are not currently supported in the Ultra Experience mode for courses.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk