What platform of Blackboard is required?

Qwickly currently requires the Community Engagement system for Blackboard if you would like to install the module. Other versions of Blackboard will allow you to install the tool version of Qwickly.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk